Skip to content

Free Shipping on orders above Dhs. 1,000

Start typing to find products

Looking for something? Try searching by category, product name, or brand.

 Lenovo ThinkCentre neo 50a 27 Gen 5 Intel Core 7 240H 68.6 cm (27") 

Synology RackStation RS11626xs+ Storage server Rack (3U) EPYC 64 GB DDR4

HPE Aruba Networking Aruba 6100 48G Class4 PoE 4SFP+ 370W Managed L3 Gigabit

 Lenovo ThinkCentre neo 50a 27 Gen 5 Intel Core 7 240H 68.6 cm (27") 

Synology RackStation RS11626xs+ Storage server Rack (3U) EPYC 64 GB DDR4

HPE Aruba Networking Aruba 6100 48G Class4 PoE 4SFP+ 370W Managed L3 Gigabit

Your cart is empty

Continue shopping
Skip to product info
5MP, 7" LCD, 720p30 HD, Wi-Fi, Bluetooth, Ethernet, USB 2.0, RJ-9, PoE, Android 9.0, 259.4 x 220 x 215 mm

Description

T58W(Pro) with Camera

*T58W Pro with Camera is equipped with the Bluetooth handset BTH58 by default.
Elite Desktop Collaboration Device

Next-Gen Desktop Collaboration

Featuring a vivid 7-inch touchable and adjustable color screen, the T58W(Pro) with Camera is positioned to bring premium-level, industry-leading communication journey with the new UI, five-megapixel camera and multi-way audio/video mixed conferencing.

Free from Cord Constraint, Free from Distracting Noise

Adopting the innovative Bluetooth handset, Yealink T58W Pro with Camera pervades wireless communication by allowing the user to move around freely and conveniently.

The professional hardware and the cutting-edge acoustic algorithm of Yealink makes the T58W Series an expert at eliminating noise and keeping every conversation clear and focus.

Take Smart Business Phone to the Next Level

Boost by the upgraded chipsets, the T58W Series comes with enhanced system performance with fast response and reinforced processing capacity. The adoption of Android 9.0 OS also improves the data encryption, authority management, response speed and integratability to meet requirements of modern business and future sustainability.

Enterprise-level Security, Provision and Management

Taking data security as one of the most significant concerns, the new set of phones adopt Arm TrustZone technology to safeguard various ARM-based data and applications.

By supporting Yealink/Unify Square Device Management Platform, the management, provision and update of the T58W Series can be implemented in a streamlined and simplified manner.

Specifications

Features
Number of function keys 7
Dual-Tone Multi-Frequency (DTMF) modes In-band, Out-of band, SIP info
Integrated voicemail Yes
Handset type Wired handset
Wall mountable Yes
Keypad number of keys 27
Product colour Grey
Hearing aid compatibility Yes
Technical details
Number of function keys 7
Dual-Tone Multi-Frequency (DTMF) modes In-band, Out-of band, SIP info
Integrated voicemail Yes
Answering machine Yes
Handset type Wired handset
Speakerphone Yes
Keypad number of keys 27
Hearing aid compatibility Yes
Security
Security algorithms 256-bit AES, HTTPS, TLS, WPA2, WPA3
Design
Product type IP Phone
Handset type Wired handset
Wall mountable Yes
Product colour Grey
Performance
Dual-Tone Multi-Frequency (DTMF) modes In-band, Out-of band, SIP info
Hearing aid compatibility Yes
Phone features
Message-waiting indicator (MWI) Yes
Call transfer Yes
Call return Yes
Answering machine Yes
Speed dialling Yes
Redialing Yes
Phonebook capacity 1000 entries
Intercom Yes
Full duplex Yes
Do not disturb function Yes
Conference call Yes
Caller ID Yes
Call waiting Yes
Call pick up Yes
Call park Yes
Call hold Yes
Call forwarding Yes
Anonymous call rejection Yes
Anonymous call Yes
Management features
Number of function keys 7
Integrated voicemail Yes
Keypad number of keys 27
Display
Touchscreen type Capacitive
Touchscreen Yes
Display resolution 1024 x 600 pixels
Display diagonal 17.8 cm (7")
Display LCD
Camera
Front camera Yes
Front camera resolution (numeric) 5 MP
Audio
Comfort noise generation (CNG) Yes
Automatic gain control Yes
Voice codecs G.711a, G.722, G.723.1, G.726, G.729, G.729A, G.729B, iLBC
Voice activity detection Yes
Speakerphone Yes
Noise reduction Yes
Microphone mute Yes
Adaptive jitter buffers Yes
Packet loss concealment (PLC) Yes
Video
Video codecs H.264 High Profile, H.264, VP8
Video resolutions 1280 x 720 pixels
Network
Networking standards IEEE 802.11a, IEEE 802.11b, IEEE 802.11g, IEEE 802.11n, IEEE 802.1x, IEEE 802.3af
Ethernet LAN interface type Gigabit Ethernet
Ethernet LAN data rates 1000 Mbit/s
Bluetooth version 4.2
Wi-Fi standards 802.11a, 802.11b, 802.11g, Wi-Fi 4 (802.11n)
Wi-Fi Yes
Supported network protocols IPv4/IPv6, SIP v1 (RFC2543), v2 (RFC3261), UDP/TCP/DNS-SRV (RFC 3263)
Security algorithms 256-bit AES, HTTPS, TLS, WPA2, WPA3
Quality of Service (QoS) support Yes
Ethernet LAN Yes
Bluetooth Yes
Colour
Product colour Grey
Microphone
Microphone mute Yes
Ergonomics
Wall mountable Yes
Ports & interfaces
USB 2.0 ports quantity 2
RJ-9 ports quantity 2
Ethernet LAN (RJ-45) ports 2
Power
Power over Ethernet (PoE) Yes
USB output current 0.5 A
Power consumption (Power over Ethernet (PoE)) 9 W
Operational conditions
Operating temperature (T-T) 0 - 45 °C
Operating relative humidity (H-H) 5 - 90%
Weight & dimensions
Width 259.4 mm
Depth 220 mm
Height 239 mm
Package width 324 mm
Package depth 293 mm
Package height 128 mm
Weight 8.88 kg
Package weight 9.56 kg
Packaging content
Number of handles included 1 pc(s)

Yealink 1201606 IP phone Grey LCD Wi-Fi

Vendor: Yealink

SKU: 1201606

Regular price Dhs. 1,354.58
Low stock (2 units)

Need bulk pricing or a custom order?

5MP, 7" LCD, 720p30 HD, Wi-Fi, Bluetooth, Ethernet, USB 2.0, RJ-9, PoE, Android 9.0, 259.4 x 220 x 215 mm

Description

T58W(Pro) with Camera

*T58W Pro with Camera is equipped with the Bluetooth handset BTH58 by default.
Elite Desktop Collaboration Device

Next-Gen Desktop Collaboration

Featuring a vivid 7-inch touchable and adjustable color screen, the T58W(Pro) with Camera is positioned to bring premium-level, industry-leading communication journey with the new UI, five-megapixel camera and multi-way audio/video mixed conferencing.

Free from Cord Constraint, Free from Distracting Noise

Adopting the innovative Bluetooth handset, Yealink T58W Pro with Camera pervades wireless communication by allowing the user to move around freely and conveniently.

The professional hardware and the cutting-edge acoustic algorithm of Yealink makes the T58W Series an expert at eliminating noise and keeping every conversation clear and focus.

Take Smart Business Phone to the Next Level

Boost by the upgraded chipsets, the T58W Series comes with enhanced system performance with fast response and reinforced processing capacity. The adoption of Android 9.0 OS also improves the data encryption, authority management, response speed and integratability to meet requirements of modern business and future sustainability.

Enterprise-level Security, Provision and Management

Taking data security as one of the most significant concerns, the new set of phones adopt Arm TrustZone technology to safeguard various ARM-based data and applications.

By supporting Yealink/Unify Square Device Management Platform, the management, provision and update of the T58W Series can be implemented in a streamlined and simplified manner.

Specifications

Features
Number of function keys 7
Dual-Tone Multi-Frequency (DTMF) modes In-band, Out-of band, SIP info
Integrated voicemail Yes
Handset type Wired handset
Wall mountable Yes
Keypad number of keys 27
Product colour Grey
Hearing aid compatibility Yes
Technical details
Number of function keys 7
Dual-Tone Multi-Frequency (DTMF) modes In-band, Out-of band, SIP info
Integrated voicemail Yes
Answering machine Yes
Handset type Wired handset
Speakerphone Yes
Keypad number of keys 27
Hearing aid compatibility Yes
Security
Security algorithms 256-bit AES, HTTPS, TLS, WPA2, WPA3
Design
Product type IP Phone
Handset type Wired handset
Wall mountable Yes
Product colour Grey
Performance
Dual-Tone Multi-Frequency (DTMF) modes In-band, Out-of band, SIP info
Hearing aid compatibility Yes
Phone features
Message-waiting indicator (MWI) Yes
Call transfer Yes
Call return Yes
Answering machine Yes
Speed dialling Yes
Redialing Yes
Phonebook capacity 1000 entries
Intercom Yes
Full duplex Yes
Do not disturb function Yes
Conference call Yes
Caller ID Yes
Call waiting Yes
Call pick up Yes
Call park Yes
Call hold Yes
Call forwarding Yes
Anonymous call rejection Yes
Anonymous call Yes
Management features
Number of function keys 7
Integrated voicemail Yes
Keypad number of keys 27
Display
Touchscreen type Capacitive
Touchscreen Yes
Display resolution 1024 x 600 pixels
Display diagonal 17.8 cm (7")
Display LCD
Camera
Front camera Yes
Front camera resolution (numeric) 5 MP
Audio
Comfort noise generation (CNG) Yes
Automatic gain control Yes
Voice codecs G.711a, G.722, G.723.1, G.726, G.729, G.729A, G.729B, iLBC
Voice activity detection Yes
Speakerphone Yes
Noise reduction Yes
Microphone mute Yes
Adaptive jitter buffers Yes
Packet loss concealment (PLC) Yes
Video
Video codecs H.264 High Profile, H.264, VP8
Video resolutions 1280 x 720 pixels
Network
Networking standards IEEE 802.11a, IEEE 802.11b, IEEE 802.11g, IEEE 802.11n, IEEE 802.1x, IEEE 802.3af
Ethernet LAN interface type Gigabit Ethernet
Ethernet LAN data rates 1000 Mbit/s
Bluetooth version 4.2
Wi-Fi standards 802.11a, 802.11b, 802.11g, Wi-Fi 4 (802.11n)
Wi-Fi Yes
Supported network protocols IPv4/IPv6, SIP v1 (RFC2543), v2 (RFC3261), UDP/TCP/DNS-SRV (RFC 3263)
Security algorithms 256-bit AES, HTTPS, TLS, WPA2, WPA3
Quality of Service (QoS) support Yes
Ethernet LAN Yes
Bluetooth Yes
Colour
Product colour Grey
Microphone
Microphone mute Yes
Ergonomics
Wall mountable Yes
Ports & interfaces
USB 2.0 ports quantity 2
RJ-9 ports quantity 2
Ethernet LAN (RJ-45) ports 2
Power
Power over Ethernet (PoE) Yes
USB output current 0.5 A
Power consumption (Power over Ethernet (PoE)) 9 W
Operational conditions
Operating temperature (T-T) 0 - 45 °C
Operating relative humidity (H-H) 5 - 90%
Weight & dimensions
Width 259.4 mm
Depth 220 mm
Height 239 mm
Package width 324 mm
Package depth 293 mm
Package height 128 mm
Weight 8.88 kg
Package weight 9.56 kg
Packaging content
Number of handles included 1 pc(s)